PayJoy

Partial Sales Outage
Identified·Partial outage

Identified – PayJoy Services

We have identified the cause of the issue affecting some PayJoy services.

Our team is actively working on applying the appropriate corrections to resolve the incident as quickly as possible. Further updates will be shared as progress continues.

Thu, Dec 18, 2025, 08:17 PM
(4 days ago)
·
Affected components
Sales
Updates

Identified

Identified – PayJoy Services

We have identified the cause of the issue affecting some PayJoy services.

Our team is actively working on applying the appropriate corrections to resolve the incident as quickly as possible. Further updates will be shared as progress continues.

Thu, Dec 18, 2025, 08:17 PM

Investigating

Investigating – PayJoy Services

We are currently investigating a potential incident that may be impacting some PayJoy services.

Our team is actively assessing the situation to determine the scope and root cause of the issue. We will provide updates as soon as more information becomes available.

Thank you for your patience and understanding.

Wed, Dec 17, 2025, 05:37 PM(1 day earlier)